[FIX] Unable to create mailbox

Article ID: 2137 
Last Review: Oct,6 2008
Author: Basalyko Roman APPLIES TO:
  • Plesk 7.6.x for Windows
  • Plesk 8.1 for Windows
  • Plesk 8.2 for Windows

Symptoms

SmarterMail 4.x is used as default mail server for Plesk.

Mailbox creation fails on every domain in Plesk. The following error is displayed:

Error: Unable to update the mail name properties:mailmng failed: Can't create mail name.
Domain: domain_name [domain_name]. Mail name: mail_name.

Event Viewer shows the following:

Event Type:     Error
Event Source:   mailmng.exe
Event Category: None
Event ID:       1
Date:           5/4/2007
Time:           5:00:15 PM
User:           N/A
Computer:       VEWEB01
Description:
Can't create mail name.
Domain: domain_name [domain_name].
Mail name: mail_name.
Reason: Failed to add the alias 'mail_name'
   at (SmarterMail::SMMailName::throwMailNameError line 652)
   at execute console command --add-mailname(vconsoleapp::start line 128)
   at execute "C:\Program Files\SWsoft\Plesk\admin\bin\mailmng.exe" --add-mailname "--domain-name=domain_name"
"--mailname=mail_name"(vconsoleapp::run line 138)
Execute file name: C:\Program Files\SWsoft\Plesk\admin\bin\mailmng.exe

Cause

The issue is caused by SmarterMail configuration which conflicts with settings applied by Plesk.

Resolution

Login to SmarterMail, go to Security,  Forwarding Black List and make sure that there is no domain named noname.com. If so please remove it from there.
Subscription for this article changesSubscription for this article changes

Please provide feedback on this article

Did this article help you solve your issue?
Yes
No
Partially
I do not know yet
 
Strongly Agree   Strongly Disagree
  9 8 7 6 5 4 3 2 1
The article is easy to understand
The article is accurate
Additional Comments:
*Please provide us with your email address in case we need to contact you.
captcha *Please type the code you can see.
* - required fields