[FIX] Sitebuilder site owner keeps Client privileges instead of Domain Admin after Plesk upgrade from 7.6.1 up to 8.2 version.

Article ID: 1999 
Last Review: Oct,6 2008
Author: Basalyko Roman APPLIES TO:
  • Sitebuilder 3.x for Windows
  • Plesk 7.6.1 for Windows
  • Sitebuilder 4.0 for Windows
  • Plesk 8.2 for Windows

Symptoms

1. A  client with domain and domain admin account has been created before upgrading Plesk  from 7.6.1 to 8.2 was done.

2. During upgrade with WSB_UPGRADE=force option Sitebuilder has been upgraded successfully, however site owner is still a Plesk Client and not a a  Domain Admin.

The following information can be found in logs:

(21:53:17) Start action Updating SiteBuilder user model...

ExecuteList: Updating SiteBuilder user model...

Execute  cmd /c "C:\plesk\admin\bin\sitebuilder.exe" --update761

Output:

Client mydomains updated

Plesk errors occured :  The limit on the number of SiteBuilder sites is reached

The limit on the number of SiteBuilder sites is reached The limit on the number

of SiteBuilder sites is reached

(21:53:31) Successful action Updating SiteBuilder user model...

Cause

Most likely default Sitebuilder license is installed on the server, what leads to incorrect upgrading of user structure.

Resolution

Please run the following command to fix the issue:

"%plesk_bin%\sitebuilder.exe" --update761
Keywords: sitebuilder upgrade


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